Migración de EIGRP Classic Mode a Named Mode

Desde la versión de IOS XE 3.11S y IOS 15.4(1)S, Cisco incorporó un comando para la migración de EIGRP Classic Mode a Named Mode. El comando es eigrp upgrade-cli, el cual se aplica en la configuración de protocolo, y este convierte un modo a otro, pero no viceversa.

Dentro del uso de este comando, podemos encontrar las siguientes restricciones:

  • Si se poseen varias configuraciones de EIGRP clásico, es necesario usar el comando en cada una de estas.
  • Este comando bloquea el equipo, y no acepta comandos hasta que la conversión se complete, donde el tiempo depende de la cantidad de configuración.
  • Como se comentó antes, este proceso solo se puede hacer desde el modo clásico al nombrado, pero no viceversa.
  • Esta configuración queda guardada en la running-config, por lo tanto, si se reinicia el equipo sin guardar la configuración, este vuelve con EIGRP Classic.
  • Después de la migración, el protocolo realiza un graceful restart para sincronizar una vez más las rutas con sus vecinos.

NOTA: otra cosa para tener en cuenta, y que no he encontrado en la documentación de Cisco, es que al momento de migrar múltiples configuraciones de EIGRP al modo nombrado, no se puede usar el mismo nombre en estas.

A continuación mostraré el procedimiento de la migración de EIGRP Classic Mode a Named Mode usando dos routers (con IOS 15.6(2)T).

La configuración que tienen ambos es EIGRP clásico:

-------- # R1 # --------

R1#show run | sec eigrp|ipv6 unicast|0/0
ipv6 unicast-routing
interface GigabitEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2000:12::1/64
 ipv6 eigrp 12
router eigrp 12
 network 192.168.12.1 0.0.0.0
ipv6 router eigrp 12
 eigrp router-id 1.1.1.1
R1#

-------- # R2 # --------

R2#show run | sec eigrp|ipv6 unicast|0/0
ipv6 unicast-routing
interface GigabitEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2000:12::2/64
 ipv6 eigrp 12
router eigrp 12
 network 192.168.12.2 0.0.0.0
ipv6 router eigrp 12
 eigrp router-id 2.2.2.2
R2#

Y vemos la vecindad creada entre los routers:

-------- # R1 # --------

R1#show ip eigrp ne
EIGRP-IPv4 Neighbors for AS(12)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.12.2            Gi0/0                    12 00:04:45    1  3000  0  1
R1#show ipv6 eigrp ne
EIGRP-IPv6 Neighbors for AS(12)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Gi0/0                    10 00:04:21   11   100  0  6
    FE80::5200:FF:FE02:0
R1#

-------- # R2 # --------

R2#show ip eigrp ne
EIGRP-IPv4 Neighbors for AS(12)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.12.1            Gi0/0                    14 00:04:14 1991  5000  0  1
R2#show ipv6 eigrp ne
EIGRP-IPv6 Neighbors for AS(12)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Gi0/0                    13 00:03:49   17   153  0  6
    FE80::5200:FF:FE01:0
R2#

Y ahora cambiamos el modo con el comando mágico creado por Cisco:

R1(config)#router eigrp 12
R1(config-router)#eigrp upgrade-cli ?
  WORD  EIGRP Virtual-Instance Name

R1(config-router)#eigrp upgrade-cli wf-eigrp-r1
Configuration will be converted from router eigrp 12 to router eigrp wf-eigrp-r1.
Are you sure you want to proceed? ? [yes/no]: yes
R1(config)#
*Feb 14 01:55:38.191: EIGRP: Conversion of router eigrp 12 to router eigrp wf-eigrp-r1 - Completed.
R1(config)#
*Feb 14 01:55:48.192: %DUAL-5-NBRCHANGE: EIGRP-IPv4 12: Neighbor 192.168.12.2 (GigabitEthernet0/0) is resync: route configuration changed
R1(config)#
R1(config)#ipv6 router eigrp 12
R1(config-rtr)#eigrp upgrade-cli wf-eigrp-r1
% A Named mode router with 'wf-eigrp-r1' already exists
R1(config)#
R1(config)#ipv6 router eigrp 12             
R1(config-rtr)#eigrp upgrade-cli wf-eigrpipv6-r1
Configuration will be converted from router eigrp 12 to router eigrp wf-eigrpipv6-r1.
Are you sure you want to proceed? ? [yes/no]: yes
R1(config)#
*Feb 14 01:57:13.734: EIGRP: Conversion of router eigrp 12 to router eigrp wf-eigrpipv6-r1 - Completed.
R1(config)#
*Feb 14 01:57:23.735: %DUAL-5-NBRCHANGE: EIGRP-IPv6 12: Neighbor FE80::5200:FF:FE02:0 (GigabitEthernet0/0) is resync: route configuration changed
R1(config)#
R1(config)#do show run | sec eigrp
router eigrp wf-eigrp-r1
 !
 address-family ipv4 unicast autonomous-system 12
  !
  topology base
  exit-af-topology
  network 192.168.12.1 0.0.0.0
 exit-address-family
router eigrp wf-eigrpipv6-r1
 !
 address-family ipv6 unicast autonomous-system 12
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  af-interface GigabitEthernet0/0
   no shutdown
  exit-af-interface
  !
  topology base
  exit-af-topology
  eigrp router-id 1.1.1.1
 exit-address-family
R1(config)#

Como vemos, no es complicada la migración, solo debemos definir el nombre el proceso de EIGRP, y especificar que si queremos proceder con la tarea.

Otra cosa que podemos observar es que al momento de cambiar la configuración de EIGRP para IPv6, no nos deja usar el mismo nombre de proceso usado anteriormente para poder mantener los address-families juntos bajo un mismo proceso de EIGRP.

Al momento de finalizada la migración, podemos ver que no queda configuración de EIGRP Classic Mode.

Agregar un comentario

Su dirección de correo no se hará público. Los campos requeridos están marcados *