Configuración básica de EIGRP Named

Desde el release de IOS 15.0(1)M, Cisco incorporó un nuevo método de configuración a EIGRP, donde el método de configuración con AS es denominado Classic Mode EIGRP, y el nuevo modo, el cual permite trabajar con address-families es denominado Named Mode.

Las características que posee EIGRP nombrado son:

  • Toda la configuración de EIGRP (IPv4, IPv6 y configuración de interfaz) concentrada bajo la configuración de protocolo.
  • Soporta todas las características de Classic Mode EIGRP (y las futuras caracterísiticas que le incluyan al protocolo).
  • Soporte de múltiples address-families y VRF.
  • Soporta un wide metric de 64 bits.

Como se menciona anteriormente, EIGRP Named se configura en base a address-families, y para este post, utilizaré la siguiente topología para demostrar la configuración básica de este nuevo método:

Lo primero que haremos será configurar el direccionamiento de los equipos:

R1:

R1(config)#int f0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#ipv6 address 2000:12::1/64
R1(config-if)#no sh
R1(config-if)#
*Feb  2 18:05:34.734: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Feb  2 18:05:35.734: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#int f1/0
R1(config-if)#no sh                     
R1(config-if)#
*Feb  2 18:05:47.766: %LINK-3-UPDOWN: Interface FastEthernet1/0, changed state to up
*Feb  2 18:05:48.766: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#ipv6 address 2000:13::1/64
R1(config-if)#int lo0
R1(config-if)#
*Feb  2 18:10:15.054: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R1(config-if)#ip address 10.10.0.1 255.255.255.0
R1(config-if)#ipv6 address 2001::1/64

R2:

R2(config)#int f0/0
R2(config-if)#no sh
R2(config-if)#
*Feb  2 18:08:26.342: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Feb  2 18:08:27.342: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#ipv6 address 2000:12::2/64
R2(config-if)#int lo0
R2(config-if)#
*Feb  2 18:08:59.558: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip address 10.20.0.1 255.255.255.0
R2(config-if)#ipv6 address 2002::1/64

R3:

R3(config)#int f0/0
R3(config-if)#no sh
R3(config-if)#
*Feb  2 18:13:37.638: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Feb  2 18:13:38.638: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#ip address 192.168.13.2 255.255.255.0
R3(config-if)#ipv6 address 2000:13::2/64
R3(config-if)#int lo0
R3(config-if)#
*Feb  2 18:14:05.210: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R3(config-if)#ip address 10.30.0.1 255.255.255.0
R3(config-if)#ipv6 address 2003::1/64

Comprobamos conectividad entre los equipos:

R1#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 24/30/40 ms
R1#ping 192.168.13.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 12/21/28 ms
R1#ping 2000:12::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:12::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/32/92 ms
R1#ping 2000:13::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:13::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/52/188 ms
R1#

Luego configuramos el proceso de EIGRP, donde en vez de usar un número de sistema autónomo, lo iniciamos con un nombre (también no olvidar iniciar el forwarding de IPv6):

R1:

R1(config)#ipv6 unicast-routing 
R1(config)#router eigrp ?
  <1-65535>  Autonomous System
  WORD       EIGRP Virtual-Instance Name

R1(config)#router eigrp wf-eigrp-r1
R1(config-router)#

R2:

R2(config)#ipv6 unicast-routing 
R2(config)#router eigrp wf-eigrp-r2
R2(config-router)#

R3:

R3(config)#ipv6 unicast-routing 
R3(config)#router eigrp wf-eigrp-r3
R3(config-router)#

Como ven, no es necesario que el proceso tenga el mismo nombre en todos los routers (como lo es en OSPF), solo es necesario que la configuración dentro del proceso use el mismo sistema autónomo.

El siguiente paso es definir la instancia de EIGRP a través de las address-families, donde se puede especificar el protocolo a usar (IPv4/IPv6), la VRF si se desean utilizar, y el AS:

R1:

R1(config-router)#address-family ?
  ipv4  Address family IPv4
  ipv6  Address family IPv6

R1(config-router)#address-family ipv4 unicast autonomous-system 123
R1(config-router-af)#

R2:

R2(config-router)#address-family ipv4 unicast autonomous-system 123
R2(config-router-af)#

R3:

R3(config-router)#address-family ipv4 unicast autonomous-system 123
R3(config-router-af)#

Como podemos ver en rojo, podemos identificar que pasamos al submodo de configuración de address-families.

Y para seguir con la configuración, y lo último que se necesita para lo básico, es habilitar el proceso en la interfaz con el comando network:

R1:

R1(config-router-af)#network 192.168.12.1 0.0.0.0
R1(config-router-af)#network 192.168.13.1 0.0.0.0
R1(config-router-af)#network 10.10.0.1 0.0.0.0

R2:

R2(config-router-af)#network 192.168.12.2 0.0.0.0
R2(config-router-af)#
*Feb  6 23:53:28.315: %DUAL-5-NBRCHANGE: EIGRP-IPv4 123: Neighbor 192.168.12.1 (FastEthernet0/0) is up: new adjacency
R2(config-router-af)#network 10.20.0.1 0.0.0.0

R3:

R3(config-router-af)#network 192.168.13.2 0.0.0.0
R3(config-router-af)#   
*Feb  6 23:55:58.191: %DUAL-5-NBRCHANGE: EIGRP-IPv4 123: Neighbor 192.168.13.1 (FastEthernet0/0) is up: new adjacency
R3(config-router-af)#network 10.30.0.1 0.0.0.0

Y repetimos el proceso para IPv6. En IPv6 es necesario tener en cuenta que se debe crear un nuevo address-family, y solo con eso, todas las interfaces que trabajen con este protocolo (y que estén activas), quedan habilitadas con EIGRP:

-------- # R1 # --------

R1(config)#router eigrp wf-eigrp-r1
R1(config-router)#address-family ipv6 unicast autonomous-system 123 
R1(config-router-af)#

-------- # R2 # --------

R2(config)#router eigrp wf-eigrp-r2
R2(config-router)#address-family ipv6 unicast autonomous-system 123
R2(config-router-af)#
*Feb  8 11:26:56.499: %DUAL-5-NBRCHANGE: EIGRP-IPv6 123: Neighbor FE80::C801:7FF:FE0F:0 (FastEthernet0/0) is up: new adjacency
R2(config-router-af)#

-------- # R3 # --------

R3(config)#router eigrp wf-eigrp-r3
R3(config-router)#address-family ipv6 unicast autonomous-system 123
R3(config-router-af)#
*Feb  8 11:29:17.283: %DUAL-5-NBRCHANGE: EIGRP-IPv6 123: Neighbor FE80::C801:7FF:FE0F:1C (FastEthernet0/0) is up: new adjacency
R3(config-router-af)#

Y comprobamos que todo quedó bien configurado con los correspondientes comandos para cada versión del protocolo:

R1#sh ip eigrp neighbors 
EIGRP-IPv4 VR(wf-eigrp-r1) Address-Family Neighbors for AS(123)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   192.168.13.2            Fa1/0                    11 00:26:30 1516  5000  0  4
0   192.168.12.2            Fa0/0                    13 00:26:30 1513  5000  0  4
R1#sh ipv6 eigrp neighbors 
EIGRP-IPv6 VR(wf-eigrp-r1) Address-Family Neighbors for AS(123)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   Link-local address:     Fa1/0                    10 00:18:56   43   258  0  3
    FE80::C803:7FF:FE11:0
0   Link-local address:     Fa0/0                    13 00:21:18   23   138  0  4
    FE80::C802:7FF:FE10:0
R1#show ip eigrp topology 
EIGRP-IPv4 VR(wf-eigrp-r1) Topology Table for AS(123)/ID(10.10.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 192.168.12.0/24, 1 successors, FD is 13107200
        via Connected, FastEthernet0/0
P 10.20.0.0/24, 1 successors, FD is 13189120
        via 192.168.12.2 (13189120/163840), FastEthernet0/0
P 192.168.13.0/24, 1 successors, FD is 13107200
        via Connected, FastEthernet1/0
P 10.10.0.0/24, 1 successors, FD is 163840
        via Connected, Loopback0
P 10.30.0.0/24, 1 successors, FD is 13189120
        via 192.168.13.2 (13189120/163840), FastEthernet1/0

R1#show ipv6 eigrp topology 
EIGRP-IPv6 VR(wf-eigrp-r1) Topology Table for AS(123)/ID(10.10.0.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 2001::/64, 1 successors, FD is 163840
        via Connected, Loopback0
P 2002::/64, 1 successors, FD is 13189120
        via FE80::C802:7FF:FE10:0 (13189120/163840), FastEthernet0/0
P 2003::/64, 1 successors, FD is 13189120
        via FE80::C803:7FF:FE11:0 (13189120/163840), FastEthernet1/0
P 2000:12::/64, 1 successors, FD is 13107200
        via Connected, FastEthernet0/0
P 2000:13::/64, 1 successors, FD is 13107200
        via Connected, FastEthernet1/0

R1#show ip route eigrp      
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D        10.20.0.0/24 [90/103040] via 192.168.12.2, 00:28:17, FastEthernet0/0
D        10.30.0.0/24 [90/103040] via 192.168.13.2, 00:28:17, FastEthernet1/0
R1#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, ND - ND Default
       NDp - ND Prefix, DCE - Destination, NDr - Redirect, O - OSPF Intra
       OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1
       ON2 - OSPF NSSA ext 2, l - LISP
D   2002::/64 [90/103040]
     via FE80::C802:7FF:FE10:0, FastEthernet0/0
D   2003::/64 [90/103040]
     via FE80::C803:7FF:FE11:0, FastEthernet1/0
R1#show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 123"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(wf-eigrp-r1) Address-Family Protocol for AS(123)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    NSF-aware route hold timer is 240
    Router-ID: 10.10.0.1
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
      Total Prefix Count: 5
      Total Redist Count: 0

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    10.10.0.1/32
    192.168.12.1/32
    192.168.13.1/32
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.12.2          90      00:30:35
    192.168.13.2          90      00:30:35
  Distance: internal 90 external 170

R1#show ipv6 protocols 
IPv6 Routing Protocol is "connected"
IPv6 Routing Protocol is "ND"
IPv6 Routing Protocol is "eigrp 123"
EIGRP-IPv6 VR(wf-eigrp-r1) Address-Family Protocol for AS(123)
  Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
  Metric rib-scale 128
  Metric version 64bit
  NSF-aware route hold timer is 240
  Router-ID: 10.10.0.1
  Topology : 0 (base) 
    Active Timer: 3 min
    Distance: internal 90 external 170
    Maximum path: 16
    Maximum hopcount 100
    Maximum metric variance 1
    Total Prefix Count: 5
    Total Redist Count: 0

  Interfaces:
    FastEthernet0/0
    FastEthernet1/0
    Loopback0
  Redistribution:
    None  
R1#

Agregar un comentario

Su dirección de correo no se hará público. Los campos requeridos están marcados *